package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)DW\d{5,}`)
var str = `DW40056
DW4000057
DW4005
DW4005`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}