#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(CREATE TABLE.*?;)"
Local $sString = "DROP TABLE IF EXISTS `aes_interval`;" & @CRLF & _
"CREATE TABLE `aes_interval` (" & @CRLF & _
" `processcode` bigint(20) NOT NULL," & @CRLF & _
" `overstaying` int(11) NOT NULL," & @CRLF & _
" `floating` int(11) NOT NULL," & @CRLF & _
" PRIMARY KEY (`processcode`) USING BTREE" & @CRLF & _
") ENGINE = InnoDB CHARACTER SET = utf8 COLLATE = utf8_general_ci;" & @CRLF & _
"by running a RegEx that would select all in between (...) i will be able to get an output/substringed text like below:" & @CRLF & _
"" & @CRLF & _
"CREATE TABLE `aes_interval` (" & @CRLF & _
" `processcode` bigint(20) NOT NULL," & @CRLF & _
" `overstaying` int(11) NOT NULL," & @CRLF & _
" `floating` int(11) NOT NULL," & @CRLF & _
" PRIMARY KEY (`processcode`) USING BTREE" & @CRLF & _
");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")