Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^\d{0,6}(\.\d{1,2})?$
/
gm
Test String
New
123456.12 21231 123456 15465.43 23.34 6.45 12345678 123456.331
Substitution
Processing...
\n