#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(\d+%((?!\r\n)\s+))(\[((\w+)((\-\w+)?((?!\r\n)\s+)?(\w+)?((?!\r\n)\s+)?(\d+)?(\,)?(\d+)?(\.)?(\d?)((?!\r\n)\s+)?(k?B)?)?((?!\r\n)\s+)?(\w+)?\]))?(((((?!\r\n)\s+)\[)(.+)\])*(((?!\r\n)\s+)(\[)(.+))?(\r?\n)))"
Local $sString = "100% [Working]" & @CRLF & _
"" & @CRLF & _
"100% [Packages 201 kB] [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"100% [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"100% [Packages 201 kB] [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"100% [Sources 4,444 B] [Waiting for headers] [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"100% [Packages 39.0 kB] [Waiting for headers] [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"100% [Translation-en 904 kB] [Waiting for headers] [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"10% [InRelease gpgv 64.5 kB] [Waiting for headers] [Waiting for headers] [Waiti" & @CRLF & _
"" & @CRLF & _
"Reading package lists... 0%" & @CRLF & _
"" & @CRLF & _
"Reading package lists... 0%" & @CRLF & _
"" & @CRLF & _
"Reading package lists... 1%" & @CRLF & _
"" & @CRLF & _
"Reading package lists... 6%" & @CRLF & _
"" & @CRLF & _
"100% [Translation-en 4,149 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%" & @CRLF & _
"[Translation-en 409 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%" & @CRLF & _
"[Translation-en 21.2 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%" & @CRLF & _
"[Translation-en 18.6 MB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s" & @CRLF & _
"" & @CRLF & _
"100% [Working]" & @CRLF & _
"" & @CRLF & _
"100% [Packages 201 kB] [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"100% [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"100% [Working]" & @CRLF & _
"" & @CRLF & _
"100% [Packages 3,341 B] [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"100% [Waiting for headers]" & @CRLF & _
"" & @CRLF & _
"Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en" & @CRLF & _
"" & @CRLF & _
"28% [Sources 507 kB] [1 InRelease 14.2 kB/64.4 kB 22%] [Waiting for headers] [W" & @CRLF & _
"28% [Sources 507 kB] [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"28% [Sources 507 kB] [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%]" & @CRLF & _
"91% [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%] [Waiting for hea" & @CRLF & _
"" & @CRLF & _
"100% [Translation-en 363 kB] [4 Sources 221 kB/250 kB 89%] [Waiting for headers" & @CRLF & _
"100% [4 Sources 221 kB/250 kB 89%] [Waiting for headers] [5 Packages 17.0 kB/23"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")