import re
regex = re.compile(r"(^(\d+%((?!\r\n)\s+))(\[((\w+)((\-\w+)?((?!\r\n)\s+)?(\w+)?((?!\r\n)\s+)?(\d+)?(\,)?(\d+)?(\.)?(\d?)((?!\r\n)\s+)?(k?B)?)?((?!\r\n)\s+)?(\w+)?\]))?(((((?!\r\n)\s+)\[)(.+)\])*(((?!\r\n)\s+)(\[)(.+))?(\r?\n)))", flags=re.MULTILINE)
test_str = ("100% [Working]\n\n"
"100% [Packages 201 kB] [Waiting for headers]\n\n"
"100% [Waiting for headers]\n\n"
"100% [Packages 201 kB] [Waiting for headers]\n\n"
"100% [Sources 4,444 B] [Waiting for headers] [Waiting for headers]\n\n"
"100% [Packages 39.0 kB] [Waiting for headers] [Waiting for headers]\n\n"
"100% [Translation-en 904 kB] [Waiting for headers] [Waiting for headers]\n\n"
"10% [InRelease gpgv 64.5 kB] [Waiting for headers] [Waiting for headers] [Waiti\n\n"
"Reading package lists... 0%\n\n"
"Reading package lists... 0%\n\n"
"Reading package lists... 1%\n\n"
"Reading package lists... 6%\n\n"
"100% [Translation-en 4,149 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%\n"
"[Translation-en 409 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%\n"
"[Translation-en 21.2 kB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s 100%\n"
"[Translation-en 18.6 MB] 17.4 MB/s 0s 100% [Working] 17.4 MB/s 0s\n\n"
"100% [Working]\n\n"
"100% [Packages 201 kB] [Waiting for headers]\n\n"
"100% [Waiting for headers]\n\n"
"Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages\n\n\n"
"100% [Working]\n\n"
"100% [Packages 3,341 B] [Waiting for headers]\n\n"
"100% [Waiting for headers]\n\n"
"Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en\n\n"
"28% [Sources 507 kB] [1 InRelease 14.2 kB/64.4 kB 22%] [Waiting for headers] [W\n"
"28% [Sources 507 kB] [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%]\n\n\n\n"
"28% [Sources 507 kB] [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%]\n"
"91% [InRelease gpgv 15.4 kB] [1 InRelease 14.2 kB/64.4 kB 22%] [Waiting for hea\n\n"
"100% [Translation-en 363 kB] [4 Sources 221 kB/250 kB 89%] [Waiting for headers\n"
"100% [4 Sources 221 kB/250 kB 89%] [Waiting for headers] [5 Packages 17.0 kB/23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")