import re
regex = re.compile(r"@media([^{]+)\{([\s\S]+?})\s*}")
test_str = ("@media (max-width: 868px) {\n"
" aside .size-toggle {\n"
" display: none;\n"
" }\n"
"}\n\n"
"@media (max-width: 767px) {\n"
" #wrapper.sidebar-display aside {\n"
" left: 0;\n"
" transition: all 0.5s ease;\n"
" -webkit-transition: all 0.5s ease;\n"
" -moz-transition: all 0.5s ease;\n"
" -ms-transition: all 0.5s ease;\n"
" -o-transition: all 0.5s ease;\n"
" }\n"
" #wrapper.sidebar-display #top-nav {\n"
" left: 0;\n"
" right: -194px;\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")