$re = '/\<link.+?rel=["\']?(?:webmention|http\:\/\/webmention\.org\/?)[\'"]?.*?\>/';
$str = '<link rel="webmention" href=" ">
<link rel="http://webmention.org/" href=" ">
<link rel="webmention http://webmention.org/" href=" ">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);