package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<((?:[^<>]|(?R))*)>`)
var str = `<%@ Page Language="C#" %>
<td class="c1 c2 c3" colspan="2">
lorem ipsum
<div class="d1" id="div2" attrid="<%# Eval("CategoryID") %>">
testing 123
</div>
asdf
</td>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}