re = /^(10){1}|([0-9]([.][0-9][0-9]?))$/m
str = '3.03
02.01
10.0
10.00
1.12
100
5
10.2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end