$re = '/^(?=[^A-Z\n]*[A-Z][^A-Z\n]*$|(?:[^A-Z\n]*[A-Z]){6,}).{8,}$/m';
$str = 'AAaaaaaa
Aaaaaaaa
AAAAAAaa ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);