using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![0-9.]+[a-z])(\+|-)?([0-9]+)(\.[0-9]+)?";
string input = @"15000.53=1254b+21";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}