const regex = /String|\b(\w*?ring\w*)\b/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('String|\\b(\\w*?ring\\w*)\\b', 'gim')
const str = `String bellsringing = "The bells are ringing is a String";`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);