re = /String|\b(\w*?ring\w*)\b/im
str = 'String bellsringing = "The bells are ringing is a String";'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result