package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\.[^\<]+)<\/someTag>`)
var str = `<someTag>123.3</someTag>
<someTag>8623.34</someTag>
<anotherTag>12.3456</anotherTag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}