re = /(\.[^\<]+)<\/someTag>/
str = '<someTag>123.3</someTag>
<someTag>8623.34</someTag>
<anotherTag>12.3456</anotherTag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end