$re = '/((?:[^\d#-]){2,}).*$/m';
$str = 'UPS1Z3734A345
UPS 1Z68A3125
HOME DEPOT #3421
STAPLES - #123
STPLS #4560';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);