using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\da-z]+(?:-[\da-z]+)*$";
string input = @"sdh-sdj-dsjh-dh
fdgdfgdf
sjkk-sd-dd
-sdgdsj-djbjsd
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}