$re = '/(\d)(?=(?:\d{3})+(?!\d))/';
$str = '2222233333,34';
$subst = "$1.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;