$re = '/(?<!asp|vb|c\#)\.[a-zA-Z]{2,6}\b/';
$str = 'asp.net somedomain.com vb.net otherdomain.org wax.museum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);