re = /(?<!asp|vb|c\#)\.[a-zA-Z]{2,6}\b/
str = 'asp.net somedomain.com vb.net otherdomain.org wax.museum'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end