$re = '/^[A-z]([\w\d_\.])*@[\w\d_]+\.[A-z](\w{1,3})$/m';
$str = 'bbkbbk.com
bb123.com
b_knapp@gmail.com
123
bbkbbk132@gmail.na
asdf_3k3k.@hotmail.euaksl
bbkbbkK132_@gmail.net';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);