#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " *(\b\w+)\.? *(?=.*\b\1)"
Local $sString = " bb.M2.u4.F5 bb.M2.u4.F5 bb.M2.u4.F5 "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)