using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+),(\w+),(\w+),(\w+)";
string substitution = @"<Item>\n <Product type=""\1"" name=""\2"" price=""\3"" quantity=""\4"">\n</Item>";
string input = @"food,apple,10,10
sweets,candy,20,20";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}