use strict;
my $str = 'food,apple,10,10
sweets,candy,20,20';
my $regex = qr/(\w+),(\w+),(\w+),(\w+)/p;
my $subst = '<Item>\\n <Product type="\\1" name="\\2" price="\\3" quantity="\\4">\\n</Item>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";