re = /(\w+),(\w+),(\w+),(\w+)/
str = 'food,apple,10,10
sweets,candy,20,20'
subst = '<Item>\\n <Product type="\\1" name="\\2" price="\\3" quantity="\\4">\\n</Item>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result