import Foundation
let pattern = #"(\w+),(\w+),(\w+),(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
food,apple,10,10
sweets,candy,20,20
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<Item>\n <Product type="\1" name="\2" price="\3" quantity="\4">\n</Item>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)