$re = '~^(\s*<(?!/))([^<]+)>(?=[^<]+\n)((?:(?!</\2>)[\s\S])*?)(?=\n *<)(?![^>]*</\2>)~m';
$str = '<p>
string
<b>
bold
</b>
<em>italic string</em>
<b>
also(bold)
</b>
</p>';
$subst = "$1$2>$3\n$1/$2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;