re = /\d+\*{3}\s*(.*?)\s*\d+\*{3}/
str = 'The quick brown fox jumps over the lazy dog" is an 1*** English-language 2*** pangram—a phrase that contains all of the letters of the alphabet. It is commonly used for touch-typing practice. It is also used to test typewriters and computer keyboards, show fonts, and other applications involving all of the letters in the 3*** English alphabet 4***.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end