re = /^([a-zA-Z]{1,2}\d{1,2})\s*?(\d[a-zA-Z]{2})$/mi
str = 'm20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end