package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\\n|\\r)+`)
var str = `this is a line\n\rthis is a new line`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}