$re = '/(\\\\n|\\\\r)+/m';
$str = 'this is a line\\n\\rthis is a new line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);