#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?\d+\.?\d*?([1-9].*?|0[1-9].*?|0$)"
Local $sString = "2.001469, should be trimmed to 2.001" & @CRLF & _
"15 should stay as it is, since it has no decimals" & @CRLF & _
"-7.00000046598 should be trimmed to -7.0000004" & @CRLF & _
"15.135 should be trimmed to 15.1" & @CRLF & _
"0.00004123456" & @CRLF & _
".1538"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")