$re = '/^(\/lunch-box\/)[^\/]+\/?$/m';
$str = '/lunch-box/xxxxxabc/ABCD123
/lunch-box/xxxxxabc/
/lunch-box/xxxxxabc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);