$re = '/table\.advFilter=\[(\[.+\])\]/';
$str = '"#report/content-pages/a526620w98080294p102751793/?explorer-table.advFilter=[[0,"analytics.pagePath","RE","\\\\?|&|#",0],[0,"analytics.pagePath","PT","search",1],[1,"analytics.pageviews","EQ","2",0]]&explorer-table.plotKeys=[]&explorer-table.rowCount=50/"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);