re = /^([A-Za-z]|[A-Za-z][\w-]*[A-Za-z0-9])$/m
str = 'ABCDEF
a-_E
_fFGR
-FGFH
5TOTO
AB-DDFD_O0
A5
AAA5CFSDFSD9-
A
B
G
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end