$re = '~<td[^>]*>\s*(?:.(?!</td>))+\s*<\?php audioButton\("[^"]*/(.+?)","(.*?)"\);.*?\?>.*?</td>~';
$str = '<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat</td>
<td><?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);