#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<td([^>]*)>\s*((?:.(?!</td>))+\s*)\s*<\?php audioButton\("([^"]*)/.+?",".*?"\);.*?\?>.*?</td>"
Local $sString = "<td class="danish">kat" & @CRLF & _
"<?php audioButton("../../audio/words/dog","dog");?></td>" & @CRLF & _
"" & @CRLF & _
"<td class="danish">kat" & @CRLF & _
"<?php audioButton("../../audio/words/dog","dog");?></td>" & @CRLF & _
"" & @CRLF & _
"<td class="danish">kat</td>" & @CRLF & _
"<td><?php audioButton("../../audio/words/dog","dog");?></td>" & @CRLF & _
"" & @CRLF & _
"<td class="danish">kat" & @CRLF & _
"<?php audioButton("../../audio/words/dog","dog");?></td>"
Local $sSubst = "<td$1>$2<?php audioButton("$3/cat", "cat");?></td>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)