$re = '~<td([^>]*)>\s*((?:.(?!</td>))+\s*)\s*<\?php audioButton\("([^"]*)/.+?",".*?"\);.*?\?>.*?</td>~';
$str = '<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat</td>
<td><?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>';
$subst = "<td$1>$2<?php audioButton(\"$3/cat\", \"cat\");?></td>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;