import Foundation
let pattern = #"<td([^>]*)>\s*((?:.(?!</td>))+\s*)\s*<\?php audioButton\("([^"]*)/.+?",".*?"\);.*?\?>.*?</td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat</td>
<td><?php audioButton("../../audio/words/dog","dog");?></td>
<td class="danish">kat
<?php audioButton("../../audio/words/dog","dog");?></td>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<td$1>$2<?php audioButton("$3/cat", "cat");?></td>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)