re = /^(?=.*?(one))(?=.*?(two))(?=.*?(three))(?:(?:\1|\2|\3);?){3}$/m
str = 'one;two;three
two;one;three
three;two;one
one;one;two
three;one;two
onetwothree'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end