$re = '/\[(?:[^][]|(?R))*\]/';
$str = 'viel Text drumherum
[abc, 12
[345]
[yxz]
] ...
noch in der nächsten Zeile
[weiter]
und Ende';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);