# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(.*my.website.*myfile)\""
test_str = "<a class=\"URL\" href=\"http://my.website.com/a/b/cdefghijklmnopqrstuvwxyz/myfile\" target=\"_blank\">"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.