re = /"(.*my.website.*myfile)"/
str = '<a class="URL" href="http://my.website.com/a/b/cdefghijklmnopqrstuvwxyz/myfile" target="_blank">'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result