$re = '/^([^)]+\))\s+\(([^)]+)\)/';
$str = 'Hello Smith (STL Terminal) (15.0) i';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);