using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<input value=""(\w*)"" name=""A3"">";
string input = @"<input value=""AAA"" name=""A1""> <input value=""BBB"" name=""A2""> <input value=""TEXT"" name=""A3"">";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}