const regex = /<input value="(\w*)" name="A3">/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<input value="(\\w*)" name="A3">', '')
const str = `<input value="AAA" name="A1"> <input value="BBB" name="A2"> <input value="TEXT" name="A3">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}