re = /<input value="(\w*)" name="A3">/
str = '<input value="AAA" name="A1"> <input value="BBB" name="A2"> <input value="TEXT" name="A3">'
# Print the match result
str.match(re) do |match|
puts match.to_s
end