use strict;
my $str = 'Suggestions for restaurants:1. Pizza2. Burger3. Sushi4. Noodles...
I tried using regex but it still gives me gthe same output. like for example for any input:
1 . Pizza2. Burger3. Sushi4. Noodles .
I get the output 1 . Pizza2. Burger3. Sushi4. Noodles . Same without any proper numbering within the list';
my $regex = qr/\b(\d+\s*\..*?)(\d+\s*\..*?)(\d+\s*\..*?)(?=\d+\.|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}