using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(?<!10)(?<!127)\.(\d+)(?<!192\.168)(?<!172\.(1[6-9]|2[0-9]|3[0-1]))\.(\d+)\.(\d+)";
string input = @"
No match
172.16.1.1
172.16.0.0
172.16.0.0
172.31.0.1
172.20.22.22
10.255.255.255
192.168.1.1
192.168.12.34
192.168.111.222
127.255.255.255
127.0.4.4
127.0.0.1
127.255.255.255
127.123.123.123
127.1.1.1
127.12.23.56
Match
172.15.2.2
172.33.33.33
192.167.1.1
192.169.1.1
207.168.207.11
207.168.207.22
192.2.199.199
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}