# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)(?<!10)(?<!127)\.(\d+)(?<!192\.168)(?<!172\.(1[6-9]|2[0-9]|3[0-1]))\.(\d+)\.(\d+)"
test_str = ("\n\n"
"No match\n"
"172.16.1.1\n"
"172.16.0.0\n"
"172.16.0.0\n"
"172.31.0.1\n"
"172.20.22.22\n"
"10.255.255.255\n"
"192.168.1.1\n"
"192.168.12.34\n"
"192.168.111.222\n"
"127.255.255.255\n"
"127.0.4.4\n"
"127.0.0.1\n"
"127.255.255.255\n"
"127.123.123.123\n"
"127.1.1.1\n"
"127.12.23.56\n\n"
"Match\n"
"172.15.2.2\n"
"172.33.33.33\n"
"192.167.1.1\n"
"192.169.1.1\n"
"207.168.207.11\n"
"207.168.207.22\n"
"192.2.199.199\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.